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Mobile Data Collection Using ArcGIS Online 

Collector for ArcGIS: 
Exercise C1: Add data to an editable feature 
service 
Estimated time: 10 minutes 

Exercise C2: Publish an Editable 
Spreadsheet to ArcGIS Online  
Estimated time: 10 minutes 

Exercise C3: Create an empty 
geodatabase feature class 
Estimated time: 20 minutes 

Exercise C4: Publish an editable 
feature service 
Estimated time: 15 minutes 

Exercise C5: Collect data using the 
Collector for ArcGIS mobile app 
Estimated time: 20 minutes 

Total time:  75 minutes 

Survey123 for ArcGIS: 
Exercise S1: Add data to an editable feature 
service 
Estimated time: 10 minutes 

Exercise S2: Create a Survey123 using 
Excel and Share it in a Web Map 
Estimated time: 20 minutes 

Exercise S3: Create a Survey123 using 
the web and Share it in a Web Map 
Estimated time: 20 minutes 

Exercise S4: Collect data into both 
surveys using the Survey123 for 
ArcGIS mobile app 
Estimated time: 25 minutes 

Total time:  75 minutes 
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Exercise C1: Add data to an editable feature service that was created with 
Collector for ArcGIS 
 

Estimated time: 10 minutes 
 

The class will collaborate on a simple map so that you can experience the process using a 
web browser before creating a geodatabase and adding data to it via an app on your 
mobile device. 

 

In this exercise, you will: 
▪ Create a data point in an editable web layer that has already been set up in a web map. 

▪ Recognize different attribute field types and data entry options. 

Step 1: Sign in to ArcGIS Online 

a. Open a Web browser and go to ArcGIS Online: http://www.arcgis.com/home. 

b. Your ArcGIS username and password for this workshop will be provided by your 
instructor.  Please record them here: 

c. Username______________________________ 
d. Password_______________________________ 
e. Notes: This username and password will expire tonight.  You will be using an ArcGIS Online 

organization set up for the EdUC participants.  
f. This exercise requires an ArcGIS Named User account.  A public ArcGIS Online Public account 

will not work because you will be publishing a feature service. 
g. Sign in using the credentials provided by your instructor.  

 

Step 2: Search for and open the map 

A web map named Tree Mapping for Educational Workshops EdUC 2017 has been created for this 
exercise.  Inside the map an editable feature service is running.  In this exercise, you will add a tree as a point 
feature to the service using ArcGIS Online.  In Exercises 2 and 3, you will create your own services.  In 
Exercise 4, you will add to the service using the Collector for ArcGIS mobile app. 

a. In ArcGIS Online, enter Tree Mapping for Educational Workshops EdUC 2017 in the search 
box and click Search for Map, or go directly to it here:  http://arcg.is/1uG1eO  

b. The search results will look similar to the following: 

http://www.arcgis.com/home
http://arcg.is/1uG1eO


Exercise 2 
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c. Click Details, and then read the map description. 
Note that Trees_JJK is the feature service in the map.  You will be adding a tree to this map. 

d. Click Open > Open the map in the map viewer. 

Step 3: Add your data to the map 

a. Let’s build a tree map for San Diego State University.  Look in your folder:  
C:\Workshop\DataCollection and select one of the photos there, noting its species, whether it is 
deciduous or evergreen, estimating its height (ft), diameter (in), form, bark color, bark texture, 
leaf type, and condition.  

b. On the map, search for San 
Diego State University and 
zoom to it.   

c. Click Edit.  (#1 on image at 
right). 

d. Click the tree symbol (green 
triangle) in the Add Features 
panel (#2 on image), and then 
click the map to place your 
point (#3 on image).  

e. In the pop-up window, enter 
data for the tree attributes. As 
you do, observe how you are 
interacting with each attribute 
field. 

• What method are you using to enter the data (open entry or choosing from a dropdown list)? 
(Species, Bark color, Bark texture, Leaf type, and Condition are all free text; Decid_Ever 
and Form are pull-downs).   

• What type of data are you entering (text or numbers)? 
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(Diameter and Height are numbers, but there is nothing constraining the data user to enter 
numbers, and there is nothing to indicate the units that are desired, so the integrity of this 
data is at risk and the analysis could be compromised unless further constraints are added). 
 

f. In the pop-up window, click Close. 

g. To stop editing, click Edit again.  The Edit button is a toggle that turns editing on and off. 

Your classmates have been entering data, too. To see their data, you need to refresh the map. You can do that 
by zooming or panning the map. 

h. Click Bookmarks > San Diego State University. 
About how many trees have been added to the SDSU campus?  How many features are in the 
feature service right now?  (Open the Table  to find out). 

Step 4:  Test the security and integrity of the data 

a. Note that with the Click a point on the map that is not yours. 

b. In the pop-up window, click Edit. 

c. Change one of the values, and then click Close. 

d. Drag the point to a different location. 

e. Click Edit to stop editing.  What are the implications of what you just did? 

As the owner of an ArcGIS Online hosted feature service, you can control whether or not it is editable—and 
in which ways it is editable. (You change these options by editing the Feature Service’s Details.) 

As a user of an ArcGIS Online hosted feature service, such as in this example, you can also temporarily 
disable editing of that layer within your map. (The option to disable/enable editing appears in the context 
menu of an individual layer, but only when you are signed in, and only if the owner of the service has allowed 
you to edit in the first place.) 

On your own, you will want to learn how and when to use these controls so that you can create an 
appropriate instructional environment. 

Minimize your browser window. (You will use it later, in Exercise C4.) 

Basic Feature Service Publishing Workflow 
 
The steps below outline the basic workflow for designing, publishing, and using an editable feature service 
for field data collection. The exercises that follow include more detail. Additional information and exercises 
can be found in the Esri web course, Teaching with GIS: Field Data Collection Using ArcGIS. 
 

http://training.esri.com/gateway/index.cfm?fa=catalog.webCourseDetail&courseid=2868
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 6 (Optional) - Sync offline data with 
ArcGIS Online 

First, you need to identify exactly what data you will 
collect. What features will you map? What information 
will you gather? What measurements will you make? 

Next, you use ArcGIS for Desktop (ArcMap or ArcGIS 
Pro) to create an empty geodatabase feature class. This 
is where you will define the type of features, the 
attribute fields, and the symbols for your data collection 
layer.  

Next, publish the empty feature class to ArcGIS Online 
as a hosted feature service that can be edited. The data 
you collect will be stored in this layer. 

Once your feature service is in ArcGIS Online, you 
must add it to a web map. (For use with Collector, you 
must also share the map and the layer with a group.) 

It’s time to collect data! You can use a browser, as you 
did in Exercise 1, or, you can use a mobile app (such as 
Collector for ArcGIS or Survey123) to gather data with 
your smartphone or tablet computer. 

If you will be collecting data offline, there is a 6th step: 
you must sync the data back to ArcGIS Online when 
you are reconnected to the Internet.  Only certain apps 
allow you to collect offline (such as Collector and 
Survey123). 
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Exercise C2: Publish an Editable Spreadsheet to ArcGIS Online 
 

Estimated time: 10 minutes 
 

This exercise steps you through the process of publishing an editable spreadsheet to 
ArcGIS Online, which one of the fastest ways to set up a database into which you can 
collect crowdsourced data. 
 
In this exercise, you will: 

▪ Open a spreadsheet designed for the collection of trees. 

▪ Publish the spreadsheet to ArcGIS Online as a feature service. 

▪ Make your feature service editable. 

▪ Create a map that includes your feature service. 

▪ Add data to your map and feature service. 
. 

Step 1: Download spreadsheet and create a feature service  

a. Go to your workshop folder C:\Workshop\DataCollection and open the tree_collection.csv file in 
Excel (or, alternatively to http://www.josephkerski.com/tree_collection/ - and download the Tree 
Collection Spreadsheet and download it to your computer, noting its folder location).  

b. In Excel, looking at your spreadsheet:  Note the latitude, longitude, TreeSpecies, Height_m, 
Diam_cm_breast_height, and BarkColor – these are the fields and will become the attributes for 
the trees you will collect. 

c. Go to ArcGIS Online and make sure you are 
signed into your organizational account > Go 
to your “My Content” area > Once in My 
Content, Add Item > Add an Item from your 
computer > Choose the tree spreadsheet > 
Provide tags and metadata > Publish this file 
as a hosted layer, using Latitude/Longitude 
for the geocoding, as shown below.  Change 
the name slightly by placing your initials in 
the name of your hosted layer, in case there is 
already a service with the same name in this 
organizational account.  

d. Add Item. 
e. Pause while the service is created.  In the 

http://www.josephkerski.com/tree_collection/
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metadata screen that you will be placed into, create a suitable title, summary, and description.  
f. Scroll down > Enable Editing > Add Features Only > Save.  You have created an editable 

feature service simply from a spreadsheet. 

Step 2: Create a map from the feature service  

a. Scroll back up > Open > Add Layer to New Map. 
b. In your map > Choose attribute to show > Show Location Only > Done. 
c. Save your map as Tree Collection Map > Share it with your organization and select Update 

Sharing if necessary.  You have created a map that anyone in your organization could add 
content to.  

Step 3: Edit your map  

a. Change Basemap to Imagery with 
Labels.  Zoom to a place where you 
are familiar with a tree’s species > Edit 
> New Feature > Add your tree’s 
location and fill in the attributes (you 
don’t need to enter the latitude and 
longitude because your map is already 
at the desired position; and you don’t 
need the FID Feature ID), as shown 
below. 

b. Click Edit when done to close the edit 
session.  

c. Can you move the location of your 
tree or change the attributes? Why or 
why not?  (No, you cannot change the 
locations nor can you change the attributes, 
because when you created the feature service, 
you chose “Add features only.” This applies 
until you, the author of the feature service, 
change it). 

d.  Is the dropdown function enabled on any of the 
features? Why or why not?  (No, the dropdown function 
is not enabled, because when you use the spreadsheet method, 
you do not create domains or feature classes, which enable 
the dropdowns.  The advantage of the spreadsheet method is that it is quick, but the disadvantage is that no dropdowns appear.   

To create a feature service with dropdowns, you will need to create a feature class in a geodatabase, which you will now do in 
Exercise C3).  
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Exercise C3: Create an empty geodatabase feature class 
 

Estimated time: 15 minutes 
 

This exercise covers step 2 in the above workflow graphic: Creating an empty feature 
class using ArcGIS Pro.    

 

In this exercise, you will: 
▪ Create a new geodatabase and point feature class 

▪ Define a domain and assign it to a field (to create a pre-set list of attribute values) 

▪ Choose symbology and create a feature template 
 

Step 1: Examine the attribute plan 

If this were an “authentic” project, you would plan what fields you need and how they should be configured 
before you begin to work in ArcGIS Pro. In this case, the planning has been done for you.  The project will 
entail collecting data near the conference site for the Marriott Hotel’s infrastructure team. 

a. Review the worksheet below. When the time comes, the exercise will guide you to enter this 
information in ArcGIS Pro. 

 
Attribute Field Worksheet Feature class name: Pool Zone 
 Feature type: Points 

Attribute Field name Alias Data type Field length Domain name 

Object in the 
pool area 

Item  text 25 ItemType 

Height of item in 
meters Height Height (m) 

decimal number 
(Float) n/a  

Object in sun or 
shade Exposure  text 10 SunShade 

 

Step 2: Create a new ArcGIS Pro project and geodatabase 

a. Start ArcGIS Pro > Create a new project > Blank > Store your project in the C:\Users folder in a 
folder you create and name called DataCollection, with the project name marriott_project, 
checking “Create a new folder for this project.”  

b. Click on Databases and note that Pro already created a marriott_project.gdb geodatabase for you. 
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Step 3: Add a new point feature class to the geodatabase 

a. Right-click marriott_project.gdb and choose New Feature Class. 

b. In the dialog box, specify the following parameters. 

Feature Class Name: Pool_Zone  (with an _ underscore) 
Geometry Type: Point  

c. For coordinate system, go to Projected Coordinate Systems > World and choose  
WGS 1984 Web Mercator (auxiliary sphere).  (this should be there as the default already). 

Note: This is the default map projection used by ArcGIS Online. 

d. Click Run to create the feature class.  

e. Click in your geodatabase to open the Pool_Zone feature class.  Right click in Pool_Zone > 
Design > Fields to edit the fields: 

 
 

f. Now, enter your field names: 
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Note:  Object ID and Shape are required fields that are automatically created in every feature class. 

Below SHAPE, enter the first attribute field: 
Field Name: Item 
Data Type: Text 

In the Field Properties area, 
reduce the field length to 25. 

Enter the next field: 
Field Name: Height 
Alias:  Height (m) 
Data Type: Float 

g. Enter the third field: 
Field Name: Exposure 
Data Type: Text 
Length: 10  

h. Click Save. 

Step 4:  Create a geodatabase domain and assign it to an attribute field 

Next, you will create a pre-constructed list of values for the Item field. This will make data entry more 
efficient and accurate and allow for pull-down menus in a web browser and in the field. To do this, you will 
define a geodatabase domain named ItemType and another named SunShade. 

a. Close your feature class window and go back to your geodatabase.  Right click > Domains > 
Manage Domains.  

b. Under Domain Name, enter ItemType. 

c. For Description, enter Item type. 

d. Choose these domain properties: 
Field Type: Text 
Domain Type: Coded Value Domain.  

e. Enter the Coded Values as Plant and Chair, as shown below. 
Note: You need to type both the code and description twice, even though they are identical in 
this case. 

 
Next, create another domain for the Exposure attribute. You will use this one to set up symbols for the data 
collection.  Don’t click OK yet! 
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f. In the next row under Domain Name, type SunShade, and then enter the following: 

Description: Sun exposure 
Field type: Text 
Domain Type:  Coded Value Domain 
Coded values:  Enter these twice as you did above, under Code and Description: 
  Sun 
  Shade 

g. After checking your work against the graphic below > Save.  You have created your 
domains. 

  
 Next, assign the domains to their respective fields. 

h. Right-click your feature class pool_zone > Design > Fields.   

i. In the table > for the Item field name > Domain > Select ItemType. 

j. In the same way > for the Exposure field name > Domain > SunShade. 

k. Click Save. 

Step 5: Choose symbology and create a feature template 

The next step is to choose the symbology for collecting the features, and 
then save that specification as a feature template. 

In this case, you will use the Exposure field to create two symbols: Sun 
and Shade. Later, when collecting a point, you will first choose one of 
these symbols (thus populating the Exposure attribute at the same time). 

a. Right click on Pool_Zone > Add to New Map. 

b. In the Map >  Right click on Pool_Zone > Symbology  (as 
shown here)> Symbolize your layer via Categories; Unique 
values > Field 1:  Exposure > Add All Values.   

c. Make the Sun symbol a 10 point yellow circle.  Make the 
Shade symbol a 10 point gray circle as shown here. 
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Note: Notice that you are able to classify and symbolize the layer, even though there are no 
features in the layer. This is because you have assigned a 
domain to the attribute field. 

d. At the top of the Pro window -- Edit > Create Features > 
Note that Pool_Zone has already been created for you as  
a Feature Template.  

Step 6: Set the geographic extent  

Because the Pool Zone layer has no features, you cannot see the extent 
of the view. You need to make sure it includes your data collection 
area. It’s also desirable to limit the map extent for your feature service, 
unless you need it to cover the entire world. 
 

a. Note that your default basemap is Topographic, which 
will be suitable for this hotel feature data collection 
activity. 

b. Select Topographic. 

c. Zoom the map to the greater San Diego area or go to Map 
> Locate > San Diego Marriott.  Zoom in a bit more until you see some trees on the Marriott 
Hotel property and parking lot lines. 

d. To the left of the map, under Drawing Order > Right click on Map > Properties > Extent >  
Select Custom extent > Calculate from Current Visible Extent > OK.  

 

e. At the very top of the bar, save  your marriott_project Pro project.    

Keep your Pro project open for use in the next exercise. 
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Tip:  It is best to choose symbols that will be easy to see on the mobile device and against the basemap that 
will be used. For example, if you expect to use a satellite image, you may want a bright color for your 
symbols; if you expect to use a light street map, you may want a darker symbol. It is wise to experiment a bit 
with symbol color and size when setting up a project, until you gain experience.   The symbols you use for 
data collection can be changed for doing analysis later on, and again when communicating the story of your 
data. 

Exercise C4: Publish an editable feature service 
Estimated time: 15 minutes 
 

You have prepared your Pool Zone feature class. Step 3 in the workflow graphic is to 
publish it to ArcGIS Online as a hosted, editable feature service. 
 
This step requires that you use an ArcGIS Online organizational account with 
Publisher role (or, if using custom roles, permissions to publish and to create features). 
 
In this exercise, you will: 

▪ Publish the Pool Zone feature class as a hosted ArcGIS Online feature service 

▪ Enter relevant metadata for the feature service 
 

Step 1: Enter metadata in the map document 

You can save time by entering some metadata in your Pro project. If you do it now, the metadata will be 
passed along automatically to the feature service description. 

a. Right click on Map > Properties > Metadata. 

b. Enter the following information as shown below: 
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c. Select OK, then save your Pro project again. 

Step 2: Publish a feature service 

a. You should already be signed in to your ArcGIS Online organizational account, but check in the 
upper right for your credentials to make sure.  The upper right text indicates your login name. 

b. Right click on Pool_Zone > Share as Web Layer > Name:  A feature service name must be 
unique within the organization. Because everyone in the workshop is creating a similar feature 
service, you need to make a slight change to the name. 
Append the number attached to your user name to the feature service name (for example, if your 
account is EdUC301, name the feature service Pool_Zone_301). 

c. Layer Type:  Features > Give it this summary:  Feature service for objects around the Marriott 
pool.  Tags:  EdUC 2017, Data Collection, Marriott 

d. Sharing Options > your organization only (not “Everyone”).   

You can choose among several editing operations to allow on your feature service when you publish it. Any 
of these can be enabled or disabled later, as well. 

e. Configuration > Enable Editing and allow editors to:  Add, update, and delete features.  Also, 
check Apply default to features with z-values and allow geometry updates without m-value, as 
shown below: 



Copyright © Esri    Author:  Joseph Kerski. Page 15 

 

 

 

f. Click Item Description. It contains the 
information you entered in the map 
document properties. Under Access and Use 
constraints, enter “Educational Use” 

g. Click the Analyze button and review any 
error messages. You may receive a message:  
Layer’s data source is z-aware and no 
default z-value is defined.  This is OK, since 
you are not using any z values (elevations). 

h. At the bottom of the Share As Web Layer 
dialog box > Publish.  

i. When the service has been published, click 
OK in the message box. 

j. Save your project again. 

Step 3: Verify the feature service is on ArcGIS 
Online and is editable 

a. Once published, in Pro, select “manage the web layer” underneath where you selected “Publish” 
a moment ago.  This should place you in your Pool_Zone metadata page in ArcGIS Online.  
(If you don’t do this, another way to access your content is to go to http://www.arcgis.com/home 
and sign in again.)    

b. Once you are in your layer’s metadata in ArcGIS Online > Open in Map Viewer > Add layer to 
new map, as shown below. 

 

 

 

 

 

c. On your new map > Edit > Add Features > Add a point anywhere in the pool area. Verify that 
the point and the attribute data entry works as intended, as shown below. 

http://www.arcgis.com/home
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d. Delete your test points and verify that you can do that.  You should be able to because you 

authorized deletion rights earlier. 

Step 4: Populate metadata and create a map in ArcGIS Online  

a. Go to your “My Content” in ArcGIS Online.  Your Marriott_Pool_Zone feature layer (service) 
should be listed, as well as the service definition. Share them with your Organization.  

b. View Item Details for your feature service.  Note that the thumbnail image displays a default 
view.  

Tip: When setting up projects for your students, creating 
recognizable thumbnail images can make your feature 
service and map easier to identify in a search. Change it to 
the photo  fieldwork_thumbnail.jpg found in your working 
folder.) 

When you do this on your own, you will need to complete a few more 
steps to use the feature service with Collector for ArcGIS. Here is a summary of these steps, and some 
additional notes. 

• Create a map that includes the editable feature service. (Collector access maps. It does not directly 
access feature services.) 

• Collector has issues if the map contains any services that do not have editable layers (e.g., map notes, 
shapefile layers, GPX layers, etc. that are not editable [not counting the basemap layer]). 

• A map must be specifically shared with someone to be visible in Collector. The best way to do this is 
to share the map with a group, and ensure that the desired person/s are members of the group—that is, 
you (the map author) and your students (the data collectors). 
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Exercise C5: Collect field data using the Collector for ArcGIS mobile app 
 

Estimated time: 15 minutes 
 
For this workshop, the instructor has created a Marriott-San Diego map and feature service that everyone 
will use for collecting data.  This feature service is exactly like the one that you set up in Exercise 4. 

In this activity, you will: 
▪ Collect data about objects in the Marriott pool area or parking lot using the prepared ArcGIS Online 
map and feature service. 

 

Collect Data in the Field  

a. Start the location services (GPS) on your device. 
b. Open the Collector for ArcGIS app.  Use “Collector for ArcGIS Online.”  
c. Sign in with your workshop credentials. If needed, enter the URL for the Education Conference 

organization: educ.maps.arcgis.com 
d. Tap All Maps. 
e. Open the map for your workshop: 

Marriott Pool Zone Data collection EdUC 2017 Workshop 

f. Go outside and collect data!  Use + to add feature.  Select Sun or Share.  Indicate the type of 
item, indicate its height in meters, and indicate the exposure.  Add photo.  You will see the data 
that you and your classmates have collected.  

These maps will continue to be available so you may access it to practice throughout the week. The extent 
covers a bit more than the Marriott Pool in San Diego, so you may add data beyond the Marriott zone if you 
wish. 
 
● 



Page 18 Copyright © Esri 
 

Exercise S1: Add data to an editable feature service that was created with 
Survey123  
 

Estimated time: 10 minutes 
 

Several methods exist for you to collect data in the field and map that data, including: 
(1) Record data on clipboard, build table, publish table in ArcGIS Online, make it 
editable.  Add data to it via map on web browser in computer.  
(2) Use method (1) and then create a GeoForm from your editable spreadsheet. 
(3)  Use Snap2Map. Take pictures, record free text.  Create storymap of a specific theme, 
such as condition of sidewalks. \ 
(4)  Create a crowdsource story map and collect photos and free text on a theme into the 
map. 
(5) Create a geodatabase and feature class in ArcGIS Pro.  Publish to ArcGIS Online and 
make it editable.  Collect data into it with smartphone using Collector for ArcGIS app. 
(6)  Create editable table using Survey123 via Excel or web tools, collect data using 
Survey123 app or web browser on phone or computer.  
 
In this workshop, we will focus on Survey123.  Survey123 allows you to capture data anytime and 
anywhere. It works on a smartphone, laptop, or desktop as a native app and also in a web browser. 
Survey123 gives you the power of smart forms along with geography, because data captured in Survey123 
for ArcGIS is immediately available in the ArcGIS Platform.  This allows you to plan your fieldwork, 
visualize and understand your data in map form, and communicate and share your work.  Survey123 also 
allows for true crowdsourcing; in other words, citizen scientists updating data in the field without needing 
an ArcGIS Online account or having to be logged in to ArcGIS Online.   
 
In this first exercise, you will: 

▪ Add a point to a map that has already been set up with an editable feature service created from 
Survey123.  Later in this workshop, you will create your own service. 

 

Step 1: Open and fill out a Survey123 form 

a.  Open a web browser and go to the following form that has been set up with Survey123: 
 http://esriurl.com/campusvegsurvey123  
 
 This will open the following Survey: 

http://esriurl.com/campusvegsurvey123
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https://survey123.arcgis.com/share/933b03f8109e411cab344453dbd7a865  
which will look like the form shown here: 

 
Fill out the form with data about a tree 
you are familiar with.  Note that the first 
two fields contain drop-down menus 
(deciduous or evergreen; condition); the 
third field asks for integers (height in 
feet), and the fourth field asks for text 
(species). 

After filling in these 4 fields, pan the map 
or enter an address or a city, and place the 
placemark on the location of your tree.  If 
you have a photograph online of that tree 
that either you have taken or have 
permission to use, download it to your 
computer and submit it at the bottom of 
the form.  

This form was created by Joseph Kerski 
using Survey123 – you can see how easy 
it is to fill out.  As you will discover in 
this workshop, it is just as easy to create a 
survey form in Survey123. 

b.  Submit your data when done.  

c.  See the results that you and your 
classmates have submitted, on this map: 

Step 2:  Visualize survey results on a web map 

See the survey results on this map:  
http://esriurl.com/campusvegsurvey123map 
(or http://arcg.is/2l0UL2O). 
 
The map will look like this, below.  Photos, if they exist, will be listed as “attachments”: 

https://survey123.arcgis.com/share/933b03f8109e411cab344453dbd7a865
http://esriurl.com/campusvegsurvey123map
http://arcg.is/2l0UL2O
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• Do you have to be logged in to ArcGIS Online to take the survey or view the web map? 

(No.  Survey123 allows for forms to be added to by anyone; that is, truly crowdsourced.  The 
resulting map can be shared with anyone; so that anyone with the URL will be able to open 
the map, which was done here. You can choose to not share your survey with everyone, in 
which case, those wishing to add data to the survey need to have an ArcGIS Online account, 
be logged in, and have the Survey123 for ArcGIS app on their smartphone).  

Exercise S2: Create a Survey123 using Excel and Share it in a Web Map 
 

Estimated time: 15 minutes 
a. Let’s build a survey where you will collect certain types of infrastructure on campus—

living (such as shrubs and trees) and nonliving (such as light poles).  There are two 
methods to creating surveys in Survey123:  (1)  Using Excel (called “Survey123 
Connect”.  (2)  Using the website.  In this exercise, you will use the Excel “Connect” 
method, and in the next exercise, you will use the web method.  The Excel method 
gives you more functionality, including the ability for “branching” questions that lead 
to different parts of your survey, depending on the users’ response. The web method is 
as easy as other web surveys that you may have used, such as Google Forms or 
SurveyMonkey (with the additional ability to map your survey results). 
 

b. Open a Web browser and go to Survey123:   http://survey123.arcgis.com  
 

c. The Survey123 website is the heart of Survey123 for ArcGIS. From the above 
Survey123 website, you can manage your surveys, control who can contribute to 
them, and even look and understand the data submitted to your surveys. The 
Survey123 website is a web browser based application and it is available for ArcGIS 
Online users. 

 
 

http://survey123.arcgis.com/
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d. Your ArcGIS username and password for this workshop will be provided by your 
instructor.  Please record them here: 
Username______________________________ 
Password_______________________________ 

 
e. Sign in using the credentials provided by your instructor. 

 
Notes: This username and password will expire tonight.  You will be using an ArcGIS 
Online organization set up for the EdUC participants.  

 
This exercise requires an ArcGIS Named User account.  A public ArcGIS Online 
Public account will not work because you will be publishing a feature service. 
 

f. Select + Create a New Survey near the top of the web page > Using Survey123 
Connect: 
 

 
 

g. Go to Programs on your computer and access > Survey123 Connect.  Once there > 
New Survey > Give it the name Campus Infrastructure Using Connect <your initials> 
EdUC 2017 > Advanced > Create Survey.   Note that Excel opens with the basics for 
your survey that you just started. 
 

h. Inside your Excel spreadsheet, note that you have 4 worksheets:  Survey contains all 
your questions.   Choices contains the choices for those questions.  Settings contains 
the settings for your questions, and Types is a reference for properties and operators 
that you can use.  In the Survey worksheet, the fields type, name, and label are 
mandatory; all others are optional. 
 

i. You will build a spreadsheet that you can use in the field using Survey123 to collect 
“campus infrastructure.”  At the Marriott Hotel “campus”, the infrastructure will 
include 2 main categories – living and nonliving.  You also want to include the date 
and time that the data was collected, a photograph of the infrastructure object, and its 
correct position on the map. 
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j. Because one of your goals in the infrastructure survey is to give your data users a set 

of different infrastructure choices depending on whether the object is living or 
nonliving, you will use the “Cascading Select” function.  Cascading selects are used to 
restrict a list of available answers based on the answer to a previous question. This 
will make your surveys easier to use, keeping choice lists small by only presenting 
relevant options to users.  A related feature is “relevant expressions”, which are sets of 
questions that can be hidden and revealed based on previous answers using relevant 
expressions.  Cascading select and relevant expressions are features of the Survey123 
Connect (Excel spreadsheet) tool – you do not have this functionality if you set up 
your Survey123 form using the web tool. 
 

k. To set up your spreadsheet, enter the values as shown below. 
 
On the Survey worksheet, enter data as shown below.  Your data types will include 
date, time, 2 different “select_one” types, an integer (for your object height), geopoint 
(for your objects’ location), and image (for your photograph).  The names of the fields 
for your database are in the “name” column.  The labels are what appears in your 
survey.  The “hint” field are helpful notes to your data users—in this case, that they 
need to give the heights in meters and round them to the nearest integer. 
 

type name label hint 
date ReportDate Date  

time ReportTime Time  

begin group basic Collect Field Data:  

select_one LivNonLiv LivNonLiv_1 Living or Non Living?  

select_one ObjectType ObjectType_1 Select Object Type:  

end group    

integer Height_m Height_m 
Give height in meters 
rounded to nearest 
integer 

geopoint Location Location  

image Photograph Photograph  

    

Scroll to the right – under appearance for your two select_one types of variables, enter minimal 
as shown below (should be about in column I, row 5 and 6) to optimize the appearance on your 
form.   Then (should be about in column J) under default for row 2 and 3 (date and time), use 
today() and now() respectively, so that the default is today and the current time for your data 
users filling out the form. See below: 
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Scroll to the right on your Survey worksheet until you find the “choice_filter”, (should be about 
in column N), which is used to hold the expression to match the additional attribute columns on 
the Choices worksheet.   Enter the value below in the same row as your “select_one 
ObjectType” (i.e., row 6).  Note the {} curved parens needed here: 

 
 
 
 
 
 
 

 
Name and save your spreadsheet to an appropriate location on your computer.   Now you are 
ready to go to the choices worksheet (tab) in your spreadsheet.  Remember that this is the 
worksheet that contains the choices for your questions.  All of your questions are user-input as 
free text (object height), or other user input (map, photograph, date, time) with the exception of 
the Object Type and whether it is living or nonliving.  You will define the choices for those 
objects in the choices worksheet.  
 
Enter the data as shown below.  Note how LivNonLiv is the first choice that the user encounters, 
and then the ObjectType. If the user selects Living, they will see the choices “tree, shrub, or 
other living.”  If the user selects Non Living, they will see the choices “chair, bench, trashcan, or 
other nonliving.”  Pay attention to your data entry accuracy, as many of these are variable names 
that cannot be misspelled.   

  
 

list_name name label image label::language1 Object 
LivNonLiv Living Living    

LivNonLiv Non_Living Non Living    
      
ObjectType tree tree   Living 
ObjectType shrub shrub   Living 
ObjectType other_living other living   Living 
ObjectType chair chair   Non_Living 
ObjectType bench bench   Non_Living 

choice_filter 
 

 
 
 

Object=${LivNonLiv_1} 
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ObjectType trashcan trashcan   Non_Living 
ObjectType other_nonliving other nonliving   Non_Living 
      

      
 

You are almost finished! On the third worksheet (tab) in your Excel table, settings, enter the following in 
Column A, row 2.  This will be your heading for your data entry on your form.  

 
l. Save your spreadsheet again.  In the Survey123 app on your computer, Select + New 

Survey > File > Select the XLS form that you have created above. Use Form Preview 
to test your form with some data you make up.  It should look similar to this, below: 
 

 
 
 

m. Publish your survey to your ArcGIS Online account.   
n. Go to www.arcgis.com and check your My Content to make sure that your feature 

layer and your form are there.  They should be in a folder that Survey123 creates 
called “Survey <survey title> as shown in this example: 
 

http://www.arcgis.com/
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o. Check the 2 boxes left of your feature layer and form and share with your 
organization.   

p. Go to your Feature Layer (hosted) and Add layer to new map: 

 
q. On your map, in “Search” search for the Marriott Marquis at 333 W. Harbor Dr, San 

Diego, CA, and zoom to it.  Once found, zoom in more closely to the Marriott 
grounds.  Save your map, give it an appropriate title including your initials, and 
metadata, and share it with the organization.  

r. Open the Survey123 app your smartphone.  Download your survey to your phone.  
Add 1 data point to it.  

s. In your My Content in ArcGIS Online, open your web map.  You should see your new 
point in your web map.  (or examine the one I created:  
http://educ.maps.arcgis.com/home/webmap/viewer.html?webmap=21188e8b0c23490
ebcefba8e6e7356f0) which is shown below. 

 

http://educ.maps.arcgis.com/home/webmap/viewer.html?webmap=21188e8b0c23490ebcefba8e6e7356f0
http://educ.maps.arcgis.com/home/webmap/viewer.html?webmap=21188e8b0c23490ebcefba8e6e7356f0
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Exercise S3: Create a Survey123 using the Web and Share it in a Web Map 
 

Estimated time: 15 minutes 
 
In the previous exercise, you used the Survey123 Connect method to create a map-enabled survey via Excel.  
In this exercise, you will use the Survey123 web tool to create a map enabled survey.  Each method has its 
advantages:  The Excel method gives you more power (such as the ‘conditional’ effects as you used above), 
and the web method is faster.   

a. In a web browser, go to http://survey123.arcgis.com and make sure you are logged in 
to your organizational account.  Go to “My Surveys” – you should see your campus 
infrastructure Survey123 that you created in the previous exercise.  Select + Create a 
New Survey and select “Using the web designer” as shown below: 

 

http://survey123.arcgis.com/
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> Get Started 
 

b. Fill out the “Create a New Survey as shown below” using your own initials (don’t 
worry about the thumbnail unless you have an image you can use here): 

 
c. Now you are on the form where you create objects to go onto your survey.  Click and 

drag the following object to your form:  Date.    Label:  Date.  Hint:  Fill in the date 
when you collected the data.  Default Value:  Select “Submitting Date.”  Click Save. 
 

d. Click Add > Click and drag Time > Edit > Label:  Time.  Hint:  Fill in the time when 
you collected the data.  Default Value:  Select “Submitting time”.  Click Save. 
 

e. Click Add > Multiple Choice > Edit > Label:  Object Type.  Hint:  What object are 
you collecting?  Choices:  Create 4 choices:   Chair.  Tree. Shrub. Add other choice:  
Other.   Check the box for “Chair.”  Save. 
 

f. Click Add > Number > Label:  Height (m).  Hint:  Indicate object height rounded to 
nearest meter.  Default value:  1.  Click:  This is a required question.  Click:  Must be 
an integer.  Set Min/Max value:  Min = 1.  Max = 30.  Save. 
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g. Click Add > GeoPoint. Label:  Location.  Hint:  What is the location of the object?  

Default Map:  Topographic.  Home Location.  Zoom to Marriott Hotel pool area:  

 
h. Click Add > Image.  Label:  Image.  Hint:  Add your photograph of the object.  Save. 

 
i. You should now have a total of 6 items on your survey:  Date, Time, Object Type, 

Height, GeoPoint, and Image.  Check your form > save again > Preview:   Test the 
questions and verify they work as you want them to. You will not be able to “submit” 
data in preview mode.  Close Preview.  
 

j. Check the Theme and feel free to change the default color and image if you’d like.  
Check the settings.  Change message to:  Your data was sent successfully.  Have a 
great GIS Education conference! Check box:  Allow respondent to add another record.  
 

k. Publish your survey. Note that once the survey is published, you will not be able to 
modify it. Thus, good practice is to make sure your design is complete before 
publishing it.   You can save the survey as a draft or, once published, make changes 
and republish it as another survey with a different name.  
 

l. You have been working in the Design tab.  Now go to the Collaborate Tab and take 
note that you can share with everyone—thus, Survey123 allows for true 
crowdsourcing/citizen science.  Note with this option, though, on the Survey123 
Mobile app, if you share your survey with everyone, you won’t see it in “My 
Surveys.”  The reason is that if you share with everyone, most likely not “everyone” 
will have the Survey123 app, and thus, you will open surveys shared with everyone in 
your web browser.   For this exercise, share the survey only with your organization 
and the group specified by your instructor.  Also check the box to prompt the user 
how to open the survey, as shown below: 
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 Save. 

m. Note the Analyze and Data tabs.  At the moment, your survey has no data in it, but 
these two tabs will be helpful in the future as you work with surveys.   

n. Go to the Share tab: 

 
> Open the link to your survey.  Remember the choices you gave the user?  Here they 
are! 
 

o. Open your survey in your web browser.  Add a test point! 
 

p. Go to “My Content” in ArcGIS Online.  Note that you have a new folder created in 
My Content, named Survey < your Survey123 name>, as shown below: 
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Your survey that you created with the Connect Method is in a separate folder.  
 

q. In your new folder, you have 3 objects – a form, a feature layer (hosted), and a feature 
layer (hosted, view).  In your feature layer hosted > Add item to new map.  In your 
new map > zoom to 333 W. Harbor Dr, San Diego, CA >  You should see the point 
that you added a moment ago.  Set a bookmark here. For example, my map: 

http://arcg.is/CLe4O    
 

Note:  Recording the survey link from the survey123.arcgis.com is important, 
especially if you are sharing your survey with everyone in true citizen 
science/crowdsourcing mode.  The reason is that they likely will not have the 
Survey123 app, but rather, they will be opening your survey link, such as:  
https://survey123.arcgis.com/share/00db49c6f5114854b2c523b63cd20e02?open=
menu to record their data, and the map, such as:  http://arcg.is/CLe4O   to check 
their results.   Because the survey link is long, it is best to share the link via a web 
page (blog post, weebly page, etc.), and to have them check their results via the 
web map link. 

Exercise S4:  Collect data into both Surveys using the Survey123 Mobile App 
 

Estimated time: 25 minutes 
 

a. In Exercise S2, you created a field survey using the Survey123 Connect method via an 
Excel spreadsheet.  In Exercise S3, you created a field survey using the Survey123 
web method by dragging and dropping objects onto your form via the web.  Both 
methods are useful.  Now you are ready to collect data in the field!  
 

b. Go outside and collect data in the field as indicated by your instructor on the grounds 
of the Marriott: 
Use your Survey123 Mobile App > Sign in with your ArcGIS Online account 
credentials.  
  

http://arcg.is/CLe4O
https://survey123.arcgis.com/share/00db49c6f5114854b2c523b63cd20e02?open=menu
https://survey123.arcgis.com/share/00db49c6f5114854b2c523b63cd20e02?open=menu
http://arcg.is/CLe4O
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(1)  First use your survey that you created with the Connect Excel method > Add a few 
points, make observations, verify that everything is working as you intended. 
(2)  Second, use your survey that you created with the Web method > Add a few 
points, make observations, verify that everything is working as you intended. 
 

c. Congratulations!  You have used several methods to create field-based forms in this 
set of exercises: 
(1)  In Exercise “C1-C5” you used ArcGIS Pro and the Collector for ArcGIS app. 
(2)  In Exercise “S1-S4” you used Survey123 and the Survey123 for ArcGIS app. 
 
● 
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