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What Is Silverlight?What Is Silverlight?

•• Browser plugBrowser plug--in for creating rich interactive web in for creating rich interactive web 
applications.applications.

•• .NET.NET--based API based API (subset of full .NET framework)(subset of full .NET framework)
•• XAMLXAML--based UI based UI (mostly compatible subset of WPF)(mostly compatible subset of WPF)
•• MicrosoftMicrosoft’’s response to Adobe Flexs response to Adobe Flex
•• Available on Windows, Mac OS X, and LinuxAvailable on Windows, Mac OS X, and Linux



History of SilverlightHistory of Silverlight

•• Silverlight 1.0 released fall 2007Silverlight 1.0 released fall 2007
–– No .NET supportNo .NET support-- only programmable using JavaScriptonly programmable using JavaScript

•• Silverlight 2.0 released fall 2008Silverlight 2.0 released fall 2008
–– Added a .NET runtime implementation called CoreCLR to allow logiAdded a .NET runtime implementation called CoreCLR to allow logic c 

coded in any .NET compatible language using a subset of the .NETcoded in any .NET compatible language using a subset of the .NET
Framework Base Class LibraryFramework Base Class Library

•• Silverlight 3.0 is released summer 2009Silverlight 3.0 is released summer 2009
–– Added GPU hardware graphics accelerationAdded GPU hardware graphics acceleration, out, out--ofof--browser capability browser capability 

(similar to Adobe AIR), improved data binding, and much more(similar to Adobe AIR), improved data binding, and much more
–– Backwards compatible with Silverlight 2.0 applicationsBackwards compatible with Silverlight 2.0 applications
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Dictionary of conceptsDictionary of concepts

•• WPF: Windows Presentation FoundationWPF: Windows Presentation Foundation
–– Technology for defining UIs in .NET desktop applications using XTechnology for defining UIs in .NET desktop applications using XAMLAML

•• XAML: Extensible Markup LanguageXAML: Extensible Markup Language
–– XMLXML--based language used by WPFbased language used by WPF

•• LINQ: Language Integrated QueryLINQ: Language Integrated Query
–– SQLSQL--like syntax for querying and manipulating many disparate data like syntax for querying and manipulating many disparate data 

sources in .NET: LINQsources in .NET: LINQ--toto--Objects, LINQObjects, LINQ--toto--XML, LINQXML, LINQ--toto--SQL, etc.SQL, etc.
•• WCF: Windows Communication FoundationWCF: Windows Communication Foundation

–– .NET framework for creating web services (SOAP, REST, ..).NET framework for creating web services (SOAP, REST, ..)
•• XAP: A ZIP archive containing a Silverlight applicationXAP: A ZIP archive containing a Silverlight application

–– Includes the application assemblies, XAML, manifest and optionalIncludes the application assemblies, XAML, manifest and optionally ly 
supporting resources. Similar to a Java JAR file.supporting resources. Similar to a Java JAR file.
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Getting started with SilverlightGetting started with Silverlight

•• Visual Studio 2008 SP1Visual Studio 2008 SP1

•• Microsoft Silverlight 3 Tools for Visual Studio 2008 SP1Microsoft Silverlight 3 Tools for Visual Studio 2008 SP1

•• Silverlight ToolkitSilverlight Toolkit

•• Optional: Microsoft Expression Blend 3 (recommended!)Optional: Microsoft Expression Blend 3 (recommended!)
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Expression Blend and Visual StudioExpression Blend and Visual Studio

Integration designer Developer

.xaml

.sln



XAML and Expression BlendXAML and Expression Blend

•• Basis for all UI in Silverlight is XAML: Extensible Application Basis for all UI in Silverlight is XAML: Extensible Application 
Markup LanguageMarkup Language

•• XAML is an XMLXAML is an XML--based markup language originally designed for based markup language originally designed for 
WPF (Windows Presentation Foundation)WPF (Windows Presentation Foundation)

•• It is the modern equivalent of Windows FormsIt is the modern equivalent of Windows Forms
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EXAMPLE APPLICATIONEXAMPLE APPLICATION
Demo Demo 



Getting started with the ArcGIS Getting started with the ArcGIS 
API for Microsoft Silverlight API for Microsoft Silverlight 



ArcGIS API for Microsoft Silverlight/WPFArcGIS API for Microsoft Silverlight/WPF

•• Built on Silverlight and WPF PlatformBuilt on Silverlight and WPF Platform
–– Combine Rich Interactive Applications with ArcGIS Server and BinCombine Rich Interactive Applications with ArcGIS Server and Bing g 

Map Enterprise ServicesMap Enterprise Services
–– Applications rendered by Microsoft Silverlight plugApplications rendered by Microsoft Silverlight plug--inin

•• Powered by ArcGIS Server REST servicesPowered by ArcGIS Server REST services
–– Only need URL to access a GIS ServerOnly need URL to access a GIS Server

•• Free to useFree to use
–– No development or deployment license required for nonNo development or deployment license required for non--commercial commercial 

useuse
–– Access the online SDK and download the API library at the ArcGISAccess the online SDK and download the API library at the ArcGIS API API 

for Microsoft Silverlight/WPF Server Resource Centerfor Microsoft Silverlight/WPF Server Resource Center



Getting Started Getting Started 

DownloadDownload
API SetupAPI Setup

ReferenceReference
AssembliesAssemblies

In VisualIn Visual
StudioStudio

Open Open 
Template Template 

In ExpressionIn Expression
BlendBlend

Write CodeWrite Code Run Run 
ApplicationApplication

Modify Modify 
templatetemplate



Features of the APIFeatures of the API

•• TaskTask
–– FindFind
–– IdentifyIdentify
–– QueryQuery
–– Address LocatorAddress Locator

•• GeocodeGeocode
–– GeoprocessingGeoprocessing
–– RoutingRouting



Silverlight ControlsSilverlight Controls

•• Silverlight toolkitSilverlight toolkit
–– Data gridsData grids

•• Results of queryResults of query
–– ChartsCharts

•• Visualize attributesVisualize attributes

•• ESRI toolkitESRI toolkit
–– NavigationNavigation
–– Map TipsMap Tips
–– ToolbarToolbar
–– FeatureDataGridFeatureDataGrid
–– MapProgressBarMapProgressBar



Design TimeDesign Time

•• Starter TemplatesStarter Templates
–– Drag & Drop Application Creation ExperienceDrag & Drop Application Creation Experience

•• Builds on the Expression Interactivity SDKBuilds on the Expression Interactivity SDK
–– BehaviorsBehaviors
–– ActionsActions
–– TriggersTriggers



DesignDesign--time Interactivitytime Interactivity

•• BehaviorsBehaviors
–– reusable components that can be directly applied to any object oreusable components that can be directly applied to any object on the n the 

artart--boardboard
–– composed of extensible triggers, extensible actions, and behaviocomposed of extensible triggers, extensible actions, and behaviorsrs

•• ESRI delivers over a dozen new BehaviorsESRI delivers over a dozen new Behaviors
–– Clear Graphics, Maintain/Constrain Extents, Measure, PanTo and Clear Graphics, Maintain/Constrain Extents, Measure, PanTo and 

Redlining Actions, Spatial Query Actions and moreRedlining Actions, Spatial Query Actions and more……



Symbol GallerySymbol Gallery





Building and DebuggingBuilding and Debugging



Compiling Silverlight ApplicationsCompiling Silverlight Applications

•• Silverlight code is compiled to a DLL just like a traditional .NSilverlight code is compiled to a DLL just like a traditional .NET ET 
librarylibrary

•• You publish a XAP file: contains application DLL, XAML, manifestYou publish a XAP file: contains application DLL, XAML, manifest, , 
and other supporting assembliesand other supporting assemblies

•• A XAP file is simply a ZIP archive with a custom extensionA XAP file is simply a ZIP archive with a custom extension
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Deploying a Silverlight ApplicationDeploying a Silverlight Application

•• The web server must serve out the XAP file with the correct MIMEThe web server must serve out the XAP file with the correct MIME
typetype

•• IIS 7 on Windows Server 2008IIS 7 on Windows Server 2008
and Windows Vista SP1 and Windows Vista SP1 
includes correct MIME type includes correct MIME type 
by defaultby default

•• Windows Vista with no service packWindows Vista with no service pack
or other web servers must add the or other web servers must add the 
mapping manually:mapping manually:

application/xapplication/x--silverlightsilverlight--appapp
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CrossCross--domain accessdomain access

•• Requires a clientaccesspolicy.xml fileRequires a clientaccesspolicy.xml file

http://services.arcgisonline.com/clientaccesspolicy.xml



DebuggingDebugging



DebuggingDebugging





ESRI Parts for MicrosoftESRI Parts for Microsoft®®
SharePointSharePoint™™



ESRI Parts for MicrosoftESRI Parts for Microsoft®® SharePointSharePoint™™
Provides Insight By Letting You:Provides Insight By Letting You:

•• Integrate and synthesize datasets Integrate and synthesize datasets 
in a visual wayin a visual way

•• Intuitively discover:Intuitively discover:
––Complex RelationshipsComplex Relationships
––Data PatternsData Patterns
––Emerging TrendsEmerging Trends

•• Easily Share your insights with Easily Share your insights with 
others others 



Resource Center for SharePointResource Center for SharePoint™™
Coming Soon!Coming Soon!

•• Free for ArcGIS Server and MapIt UsersFree for ArcGIS Server and MapIt Users
•• Additional Cost for non ESRI usersAdditional Cost for non ESRI users

•• http://resources.esri.com/sharepointhttp://resources.esri.com/sharepoint



ESRI Parts for ESRI Parts for 
MicrosoftMicrosoft®® SharePointSharePoint™™

•• Interactive and Interactive and configurableconfigurable
–– Map, GeoList, Location Map FieldMap, GeoList, Location Map Field
–– Work with Work with 

•• Bing MapsBing Maps
•• SharePoint List (Excel)SharePoint List (Excel)
•• Form Libraries (InfoPath)Form Libraries (InfoPath)
•• SQL Server tablesSQL Server tables

–– Configure using a rich, Silverlight designConfigure using a rich, Silverlight design--
time experiencetime experience



ESRI Map Web PartESRI Map Web Part

•• Base MapsBase Maps
–– Bing MapsBing Maps
–– ArcGIS OnlineArcGIS Online
–– ArcGIS ServerArcGIS Server

•• Work with your dataWork with your data
–– Add Operational LayersAdd Operational Layers

•• List Views, SQL TablesList Views, SQL Tables
–– Configure layersConfigure layers

•• Thematic MapsThematic Maps
•• Points and areaPoints and area



GeoList Web PartGeoList Web Part

•• Interactively work with your lists and the mapInteractively work with your lists and the map
•• Common tools for viewing your lists and finding nearby itemsCommon tools for viewing your lists and finding nearby items





Road ahead 9.4Road ahead 9.4

•• MappingMapping
–– Support for standSupport for stand--alone tablesalone tables
–– Expose relationships and ability to query relationshipsExpose relationships and ability to query relationships
–– Identify and Find operations support layer definitionsIdentify and Find operations support layer definitions

•• EditingEditing
–– Feature ServiceFeature Service
–– Geometry ServiceGeometry Service
–– Web API:  FeatureLayer, Editing Toolbar & Attribute InspectorWeb API:  FeatureLayer, Editing Toolbar & Attribute Inspector
–– Editing  Control (Editing  Control (configurable out of the box editing solutionconfigurable out of the box editing solution))
–– AttachmentsAttachments



Road ahead 9.4Road ahead 9.4

•• TimeTime
–– Time aware layersTime aware layers
–– Time slider for easy displayTime slider for easy display

•• OtherOther
–– Support for Well Known Text Spatial ReferencesSupport for Well Known Text Spatial References
–– Support for Network Analyst Closest Facility and Service AreaSupport for Network Analyst Closest Facility and Service Area



Learn MoreLearn More
http://www.esri.com/traininghttp://www.esri.com/training

•• InstructorInstructor--Led TrainingLed Training
–– Introduction to ArcGIS ServerIntroduction to ArcGIS Server

•• Free Web Training SeminarFree Web Training Seminar
–– Getting Started with ArcGIS API for Microsoft Silverlight/WPFGetting Started with ArcGIS API for Microsoft Silverlight/WPF

ESRI TrainingESRI Training……keep critical skills up to datekeep critical skills up to date





Open StandardsOpen Standards

Web UsersWeb Users Web GISWeb GISArcGIS ServersArcGIS Servers GIS UsersGIS UsersArcGIS DesktopArcGIS Desktop
AuthorsAuthors

MobileMobileDesktopDesktop

Web MapWeb Map

MashupsMashups

Web MapWeb Map

MashupsMashupsExplorerExplorer

GeodatabaseGeodatabase

ArcGIS ServerArcGIS Server ArcGIS OnlineArcGIS Online MapMap MapMap MapMap Web MapWeb Map

Web MapWeb MapBrowserBrowser BrowserBrowser Web BlogWeb Blog Web BlogWeb Blog

DesktopDesktop DesktopDesktop MobileMobile MobileMobile MobileMobile

Raster FilesRaster Files



Business PartnerBusiness Partner

EducationEducationEducationEducation

Professional ServicesProfessional ServicesProfessional ServicesProfessional Services

Designing & PlanningDesigning & Planning

Situational AwarenessSituational Awareness

Tech SupportTech Support

Tech SupportTech Support

LayersLayers

ModelsModels



DatabaseDatabase

FilesFiles DocumentationDocumentation

CD/DVDCD/DVD

Data ApplianceData ApplianceInternetInternet

SatelliteSatelliteSatelliteSatellite

ArcGISArcGIS

ArcGISGISGIS

ArcGISArcGIS

ArcGISGIS



Title/Section TitleTitle/Section Title



Successful Presentation GuidelinesSuccessful Presentation Guidelines

•• Additional ESRI presentation resources available on ArcZoneAdditional ESRI presentation resources available on ArcZone
http://arczone/resources/presentations.cfmhttp://arczone/resources/presentations.cfm

•• Remember your target audienceRemember your target audience
•• Keep your slides uncluttered and to the pointKeep your slides uncluttered and to the point

–– Only use a key phrase or a few words to reinforce your pointOnly use a key phrase or a few words to reinforce your point
–– 11--5 words per bullet point5 words per bullet point
–– 33--5 bullet points per page5 bullet points per page
–– Refrain from using more than two levels of bullet pointsRefrain from using more than two levels of bullet points

•• Use several title slides for each section for brandingUse several title slides for each section for branding
–– Make it clear where you are goingMake it clear where you are going

•• Avoid too much animationAvoid too much animation
–– Keep it simpleKeep it simple



Master Template Style Example (24 point white)Master Template Style Example (24 point white)
Subtitle (16 point yellow italicSubtitle (16 point yellow italic))

•• Bulleted text (20 point with drop shadow)Bulleted text (20 point with drop shadow)

Body text (20 point with drop shadow)Body text (20 point with drop shadow)

Closing StatementClosing Statement…… (14 point yellow italic)(14 point yellow italic)



Web UsersWeb UsersGIS UsersGIS Users

MashupsMashups

GeodatabaseGeodatabase

ArcGIS ServerArcGIS Server

BrowserBrowser

ArcGIS OnlineArcGIS Online

ArcGIS ServersArcGIS Servers

MashupsMashups

ExplorerExplorerMapMap

MapMapMapMap

Web MapWeb Map

Open StandardsOpen Standards

Web MapWeb Map Web MapWeb Map

Web MapWeb Map

BrowserBrowser BrowserBrowser

Web BlogWeb Blog Web BlogWeb BlogArcGIS DesktopArcGIS Desktop
AuthorsAuthors

Web GISWeb GIS

Raster FilesRaster Files

BrowserBrowser

MashupsMashups

Raster FilesRaster FilesWeb MapWeb Map MapMapWeb MapWeb Map MapMapWeb MapWeb Map

MapMapWeb MapWeb Map MapMapWeb MapWeb Map

MapMap



GlobesGlobes LayersLayers
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FilesFiles

FilesFiles

FilesFiles

ModelsModelsModelsModels
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Business PartnerBusiness PartnerEducationEducation

Professional ServicesProfessional Services

Professional ServicesProfessional Services

Designing & PlanningDesigning & Planning Situational AwarenessSituational Awareness Tech SupportTech Support

DesktopDesktopData ApplianceData Appliance

Data ServerData Server MobileMobile

GIS UserGIS UserMobile GIS UserMobile GIS User

SatelliteSatellite SatelliteSatellite WindmillWindmill



ArcGISArcGIS ArcGISArcGIS ArcGISArcGIS ArcGISArcGIS ArcGISArcGIS ArcGISArcGIS ArcGISArcGIS

ArcGISArcGIS ArcGISArcGIS ArcGISArcGIS ArcGISArcGISArcGISArcGIS ArcGISArcGIS ArcGISArcGIS



Advantages of Using the Shared Clip Art Library:Advantages of Using the Shared Clip Art Library:
••Instant access to new icons over a shared network.Instant access to new icons over a shared network.
••Faster to import from clip art pane than by finding the slide inFaster to import from clip art pane than by finding the slide in your presentation with the your presentation with the 
icons on it.icons on it.
••Same location (clip art pane) for every presentation you work onSame location (clip art pane) for every presentation you work on..

Connect to the Shared Clip Art Collection,Connect to the Shared Clip Art Collection, ““ESRI Diagram ElementsESRI Diagram Elements””
1.1.From your PowerPoint document, go to Insert > Clip ArtFrom your PowerPoint document, go to Insert > Clip Art
2.2.Select Select ““Organize clipsOrganize clips…”…” from the bottom of the Clip Art panefrom the bottom of the Clip Art pane
3.3.Now go to File > Add Clips to Organizer > On My OwnNow go to File > Add Clips to Organizer > On My Own
4.4.Navigate to Navigate to \\\\pizzabox.esri.compizzabox.esri.com\\SpaceSpace\\••DiagramsDiagrams\\ElementsElements\\
In the File of Type box, click In the File of Type box, click ““Shared CatalogsShared Catalogs””. Select . Select ESRI_Diagram_Elements.mgcESRI_Diagram_Elements.mgc

Using the ESRI Diagram ElementsUsing the ESRI Diagram Elements
1.1.If the Clip Art pane is not already visible, go to Insert > ClipIf the Clip Art pane is not already visible, go to Insert > Clip ArtArt
2.2.To browse all icons, select To browse all icons, select ““Shared CollectionsShared Collections”” in the in the ““Search in:Search in:”” window. window. 
You may need to select all subfolders. Click Go.You may need to select all subfolders. Click Go.
3.3.Click the icon to insert it into your presentation.Click the icon to insert it into your presentation.

PowerPoint 2003 UsersPowerPoint 2003 Users——Same as Above, except:Same as Above, except:
1.1.Access the Clip Art pane by going to Insert > Picture > Clip ArtAccess the Clip Art pane by going to Insert > Picture > Clip Art..

If you travelIf you travel——you can copy the Elements folder to your hard drive. You can theyou can copy the Elements folder to your hard drive. You can then access all n access all 
the PNG files manually (PowerPoint does not let you add a local the PNG files manually (PowerPoint does not let you add a local copy as a shared catalog.)copy as a shared catalog.)

Alternative Method of Accessing ESRI Icons Via Clip ArtAlternative Method of Accessing ESRI Icons Via Clip Art


